This site may be down for up to an hour for network maintenance during the period
21 January 2022 22:30 UTC - 22 January 2022 00:30 UTC.

Difference between revisions of "Creating and Validating PDF/A-1 Documents"

From The SBN Wiki
Jump to navigation Jump to search
m
m
Line 48: Line 48:
 
** [http://docs.verapdf.org/gui/ Desktop GUI Quick Start Guide]
 
** [http://docs.verapdf.org/gui/ Desktop GUI Quick Start Guide]
 
;Backend
 
;Backend
 +
* [https://www.pdflib.com/fileadmin/pdflib/pdf/pdfa/2009-05-04-Bavaria-report-on-PDFA-validation-accuracy.pdf Bavaria Report on PDF/A Validation Accuracy]
 
* [http://docs.verapdf.org/ VeraPDF documentation]
 
* [http://docs.verapdf.org/ VeraPDF documentation]
 
** [https://github.com/verapdf VeraPDF GitHub page]
 
** [https://github.com/verapdf VeraPDF GitHub page]

Revision as of 18:33, 3 July 2017

Creation

Adobe PDFMaker settings in Microsoft Office

Microsoft Office

With Adobe Acrobat Pro DC (not to be confused with Acrobat Reader DC, which can't create or edit documents), a PDF creation tool is integrated into Microsoft Office. Creating a document compliant with PDF/A (potentially PDF/A-1a) this way can be done as follows:

  1. Create or open your document in Microsoft Office.
  2. Go to "Acrobat" → "Preferences."
  3. In the "Acrobat PDFMaker" window that opens, click on the "PDF/A Compliance" drop-down list and select "PDF/A-1a."
  4. Click "OK."
  5. Go to "Acrobat" → "Create PDF."

Without Acrobat Pro, PDF/A-1 compliance can be achieved using the "Save As" function:

  1. Create or open your document in Microsoft Office.
  2. Go to "File" → "Save As" and choose a destination folder.
  3. In the "Save As" window that opens, click on the "Save as type" drop-down list and select "PDF."
  4. Click on the "Options..." button
  5. In the "Options" window that opens, check the "ISO 19005-1 compliant (PDF/A)" box.
  6. Click "OK" → "Save."
"PDF Options" menu in LibreOffice

LibreOffice and OpenOffice

PDF creation is virtually identical in LibreOffice and OpenOffice.

  1. Create or open your document in LibreOffice or OpenOffice.
  2. Go to "File" → "Export in PDF format."
  3. In the "PDF Options" window that opens, check the "Archive PDF/A-1a" box.
  4. Click "Export."

Validation

Preflight in Adobe Acrobat Pro DC

Adobe Acrobat

The Portable Document Format (PDF) was developed by Adobe Systems, so Adobe is naturally a reliable go-to for PDF tools. The drawback, of course, is that their more useful tools are proprietary. Acrobat Reader is free but cannot validate PDF compliance. Like Acrobat Pro, Acrobat Reader will display a blue banner stating that the file "claims compliance with the PDF/A standard." While a compliant file should always yield the banner, the banner is by no means a form of sufficient validation. If you don't have Acrobat Pro, you'll have to explore other validation options, some of which are mentioned below.

If you do have the luxury of Acrobat Pro, then take advantage of its "Preflight" function to check compliance:

  1. In the toolbar, go to "PDF Standards" → "Preflight"
  2. In the "Preflight" window that opens, click on the "Libraries" drop-down list at the top (it likely is set to "Essentials" by default) and select "PDF Standards."
  3. Expand the "PDF/A compliance" heading and select "Verify compliance with PDF/A-1a." You can also attempt to convert the document to this compliance level by selecting "Convert to PDF/A-1a" instead. If this fails, select "Verify compliance with PDF/A-1b" to ensure that the document has at least reached the minimum compliance required by PDS4.

VeraPDF

See Also

External Links

General
Backend